当前位置: 主页 > 技巧 >

通达信节节髙主图指标公式

: 时间:2020-07-17 09:22

AAA:=MAX(DYNAINFO(3),DYNAINFO(5))*1.215;
BBB:=MIN(DYNAINFO(3),DYNAINFO(6))/1.215;
CCC:=AAA-BBB;
BB:=BBB+CCC*9.2/8,COLORRED;
A1:=IF(BB<HHV(H,10),BB,DRAWNULL);
AA:=BBB+CCC*8.01/8,COLORRED;
B1:=IF(AA<HHV(H,10),AA,DRAWNULL);
A8:=BBB+CCC*6.6/8,COLORRED;
C1:=IF(A8<HHV(H,10),A8,DRAWNULL);
B8:=BBB+CCC*1.5/8,COLORYELLOW;
D1:=IF(B8<HHV(H,10),B8,DRAWNULL);
D:=(AAA+BBB)/2,COLORWHITE;
E1:=IF(D<HHV(H,10),D,DRAWNULL);
E:=BBB+CCC*2/3,COLORMAGENTA;
F1:=IF(E<HHV(H,10),E,DRAWNULL);
F:=BBB+CCC/3,COLOR999900;
G1:=IF(F<HHV(H,10),F,DRAWNULL);
DRAWBAND(A1,RGB(81,31,144),B1,RGB(162,0,124));
DRAWBAND(B1,RGB(162,0,124),C1,RGB(0,174,114));
DRAWBAND(C1,RGB(0,174,114),E1,RGB(245,117,109));
DRAWBAND(G1,RGB(162,0,124),D1,RGB(81,31,144));
DRAWBAND(E1,RGB(241,175,0),G1,RGB(245,117,109));
DRAWBAND(F1,RGB(0,160,107),E1,RGB(245,117,109));
G:=(BBB+CCC)/1.6,COLORGREEN;
H1:=IF(G<HHV(H,10),G,DRAWNULL);
I:=(BBB+CCC)/1.8,COLORBLUE;
I1:=IF(I>LLV(L,60),I,DRAWNULL);
J:=(BBB+CCC)/2.1,COLORBLUE;
J1:=IF(J>LLV(L,60),J,DRAWNULL);
K:=(BBB+CCC)/2.5,COLORBLUE;
K1:=IF(K>LLV(L,60),K,DRAWNULL);
DRAWBAND(H1,RGB(238,124,107),J1,RGB(236,135,14));
DRAWBAND(K1,RGB(0,80,80),I1,RGB(236,135,14));
DRAWBAND(J1,RGB(0,0,128),K1,RGB(0,160,107));
DRAWBAND(H1,RGB(229,70,70),I1,RGB(91,189,43));
DRAWBAND(D1,RGB(208,119,11),H1,RGB(229,70,70));
M:=(BBB+CCC)/3,COLORBLUE;
L1:=IF(M>LLV(L,60),M,DRAWNULL);
N:=(BBB+CCC)/3.8,COLORBLUE;
M1:=IF(N>LLV(L,60),N,DRAWNULL);
U:=(BBB+CCC)/5.2,COLORBLUE;
N1:=IF(U>LLV(L,60),U,DRAWNULL);
DRAWBAND(L1,RGB(199,195,0),M1,RGB(91,189,43));
DRAWBAND(M1,RGB(91,189,43),N1,RGB(0,132,137));
AA10:=MA(C,N);
BB10:=ATAN((AA10-REF(AA10,1)))*180/3.1416;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),3,1),COLOR000066;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),2.6,1),COLOR000099;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),2,1),COLOR0000CC;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),1.2,1),COLOR0000FF;
STICKLINE(BB10>1 AND AA10>REF(AA10,1), AA10,REF(AA10,1),0.4,1),COLORCC66FF;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),3,1),COLOR007700;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),2.6,1),COLOR009900;
STICKLINE(BB10<1 AND AA10< REF(AA10,1), AA10,REF(AA10,1),2,1),COLOR00BB00;
AA20:=MA(C,M);
BB20:=ATAN((AA20-REF(AA20,1)))*180/3.1416;
STICKLINE(BB20>1,AA20,REF(AA20,1),3,1),COLOR00AAFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),2.6,1),COLOR00CCFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),2,1),COLOR22FFFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),1.2,1),COLOR66FFFF;
STICKLINE(BB20>1,AA20,REF(AA20,1),0.4,1),COLOR99FFFF;
STICKLINE(BB20<1,AA20,REF(AA20,1),3,1),COLOR777777;
STICKLINE(BB20<1,AA20,REF(AA20,1),2.6,1),COLOR999999;

标签: 龙建股份股票 联建光电股票

声明:搜集自网络,不代表本站立场。